Failed to load map.
Incident Report for Trucker Path Status
Resolved
The issue has been resolved. Users can resolve the problem by reinstalling the app. If there are any further concerns, please contact customer service for assistance.
Posted Aug 21, 2023 - 18:00 MST
Update
If you encounter issues with map loading, you can try uninstalling and reinstalling the application. Our engineers are currently working on resolving this matter promptly.
Posted Aug 21, 2023 - 14:00 MST
Update
We have identified that our HERE SDK maps have been updated, and users will need to download the new maps.
Posted Aug 21, 2023 - 07:00 MST
Identified
Our engineers were noticed that users were not able to load map. We are investigating.
Posted Aug 21, 2023 - 06:40 MST
Investigating
Some users have reported that our maps are failing to load. Our engineering team has been notified and is currently investigating the matter.
Posted Aug 21, 2023 - 06:30 MST
This incident affected: Trucker Path Mobile App.